TeamsLink Pro Supervisor Dashboard
Incident Report for TeamsLink
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 23:30 BST
Monitoring
We have deployed a fix to the live environment and have observed positive results when testing.

We will now closely monitor all aspects of TeamsLink Pro over the next 48 hours.
Posted Apr 20, 2024 - 23:36 BST
Investigating
We are aware of an issue with the TeamsLink Pro supervisor dashboard showing incorrect call records for queued calls and calls being offered to agents.

Please note this is visual only and calls are still being routed correctly. We are performing emergency maintenance on the TeamsLink platform this evening to clear any discrepancies, further communication will be sent out shortly.
Posted Apr 19, 2024 - 16:16 BST
This incident affected: TeamsLink Portal Services (TeamsLink Pro Contact Centre).